Support > Forums > OpenBots Studio > xul dll error

xul dll error

Marco Zenere

  • Reporter
  • Calender Icon June 25,2021 at 1:08 PM

I installed OpenBots studio in Windows 10 21H1 and when I try to use the Web Element Recorder tool, it doesn't work. I have an exception (HRESULT:0x8007007E): can not load DLL xul. I try to install the DLL xul and to install OpenBots 1.4.0 but it doesn't work.

This forum has 172 topics, 459 replies, and was last updated 1 hours ago by Poornima Malv

Nataly Alvarado

  • Participant
  • Calender Icon June 29,2021 at 10:12 AM

Hi Marco,

The issue encountered with the recorder is most likely caused by your machine's configuration. Further investigation would be needed, as many factors could be affecting it.

However, the best approach to use the Element Action command is by indicating the targeted element's xpath on the Xpath field. The xpath can be modified as needed by using the site's HTML information, also variables and wildcards can be included. The best way to obtain this information is by inspecting the element on your web browser. Please, refer this Academy course for a detailed guide on Website Automation: RPA Challenge - Input Fields

Note: You will need to enroll to the course in order to access it. The demo was made in version 1.4.0.

I recommend enrolling to Academy, where you'll have access to multiple courses available, including: Essentials of RPA, Setup and Configuration and Practice Automations. After completing these courses, you have the option of taking the OpenBots Developer Certification.

In addition, our YouTube channel contains quick videos that you can use as reference to get started: OpenBots - Youtube

You are not authorized to reply, please click here to login and add your reply to this topic.