Support > Forums > OpenBots Studio > Web recorder not working properly (v1.7)

Web recorder not working properly (v1.7)

David Santos

  • Reporter
  • Calender Icon December 09,2021 at 10:16 AM

Hi Openbots experts, After the migration of the openbots studio, I am trying to generate the rpachallenge case. To get the xpath of some elements on the rpachallenge site I have tried to use the web recorder, unfortunately when the url of the rpachallenge site is entered, the page is not displayed in the web recorder window and remains blank. Do I need to remove and reinstall the "Chrome Native Messaging" extension? If so, how can I do that? Kind regards.

This forum has 172 topics, 459 replies, and was last updated an hour ago by Poornima Malv

Lakshmi Sukumar

  • Participant
  • Calender Icon December 17,2021 at 8:28 PM

David,

most of the features within Selenium are also present in Native Browser, except for the commands exclusive to Selenium like Execute Script and Switch Browser Frame. Moreover, Native Browser commands provide more tab functionality like the ability to open, activate, close and refresh a tab. As well as the ability to attach to an existing web session, send keys to a specific field and inject Js script.

We recommend using Selenium if the process requires an isolated instance, as Selenium will always create a web session free of cookies and cache.

We don't have any plans of decommissioning the Selenium commands, as many of our clients have implemented it in their processes. However, we do not plan to add or enhance the Selenium commands or recorder wither. Most of our efforts will go towards enhancing the Native Browser commands.

Hope this answered your question!

David Santos

  • Participant
  • Calender Icon December 16,2021 at 10:21 AM

Thank Nataly. Do the Native Browser commands allow all the features contained in the actions under the Selenim scope? If so, is there any activity that could be handled better using the selenium automations? If you provide less support in Selenium actions, does it mean Openbots will decomission this part in future releases? Thanks!

Lakshmi Sukumar

  • Participant
  • Calender Icon December 15,2021 at 4:08 PM

David,

I see where the confusion was. I though you were referencing the Native Element Recorder, but you are employing the OB Web Element Recorder.

I'll report this case to the development team, as you mention, I'm unable to navigate to the RPAChallenge site as well.

However, I do recommend using the Native Browser commands and recorder instead of Selenium, as we provide more support and functionality through the OpenBots extension.

You can reference this post for more information: Selenium and Native Browser

David Santos

  • Participant
  • Calender Icon December 13,2021 at 8:59 PM

My apologies, I did not get the message correctly. Find below the content of the json file. The exe file is in the place where it has to be according to the json file. Did you try "recorder tools> web element recorder" and typing "https://www.rpachallenge.com/"? So, what could be the reason some web pages are correctly opened by "recorder tools> web element recorder" and others are not?

{ "$type": "OpenBots.Core.ChromeNative.ChromeNativeServer.ManifestSettings, OpenBots.Core", "name": "com.openbots.chromeserver.message", "description": "OpenBots Native Messaging Host for Chrome", "path": "C:\Program Files (x86)\OpenBots Inc\Extensions\NativeServer\OpenBots.NativeServer.exe", "type": "stdio", "allowed_origins": [ "chrome-extension://kkepankimcahnjamnimeijpplgjpmdpp/" ] }

Regards.

Lakshmi Sukumar

  • Participant
  • Calender Icon December 13,2021 at 5:00 PM

David,

That manifest.json file is the file I referenced in my first response. This json file should contain the path to the extension executable.

However, based on your previous responses, your recorder is functioning as expected with other websites. Meaning, the extension must be configured correctly (please correct me if wrong).

I've tried using the Native Element recorder with the RPA challenge website, and did not face any issues. Is there an specific element that you can't record? or any error message that you could share?

David Santos

  • Participant
  • Calender Icon December 13,2021 at 1:32 PM

Thanks for the info. In the indicated path there are a couple of note files (see details below), however the exe file is not there.

  • com.openbots.chromeserver.message-manifest.json
  • com.openbots.ffserver.message-manifest.json Regards.

Lakshmi Sukumar

  • Participant
  • Calender Icon December 13,2021 at 12:12 AM

Hi David!

the AppData is usually a hidden folder. You should be able to access it by enabling the Hidden Items setting on your File Explorer View configurations

David Santos

  • Participant
  • Calender Icon December 11,2021 at 8:39 AM

The "AppData" folder does not exist within my username folder ("C:\Users%username%")

Lakshmi Sukumar

  • Participant
  • Calender Icon December 10,2021 at 5:57 PM

David,

Please confirm you see no OpenBots folders in your "...App Data\Local" folder.

David Santos

  • Participant
  • Calender Icon December 09,2021 at 9:42 PM

Hi Nataly. I have tried other urls and the associates sites are shown correctly in the Web element recorder window that is accessible via the recorder tools menu. It seems that the element recorder window does not work with the rpachallenge site somehow. There are no openbots folders within the path �C:\Users%UserName%". Does it mean that something in the install process was wrong? I found a Extension folder in the following path: "C:\Program Files (x86)\OpenBots Inc\Extensions\NativeServer" with the following files. Regards.

You are not authorized to reply, please click here to login and add your reply to this topic.