Support > Forums > OpenBots Studio > v1.8.0 errors with 1.7.0 packages

v1.8.0 errors with 1.7.0 packages

Chris Rose

  • Reporter
  • Calender Icon April 30,2022 at 5:36 PM

Updated to v1.8.0 and projects that require API Commands 1.7.0, or Database Commands 1.7.0 keep giving errors when loading as "default packages" or when adding to a project. Should we be waiting for v1.8.0 packages to arrive in before upgrading?

Ex 1. When making a new automation in 1.8.0, I added API Commands 1.7.0, but when I try to use a command, I get an error: Could not load type 'OpenBots.Core.Attributes.PropertyAttributes.PropertyUISelectionOption' from assembly 'OpenBots.Core, Version=1.8.0.0, Culture=neutral, PublicKeyToken=Null'

Ex 2. When trying to add API Commands 1.7.0 as a Default Package, it appears to load, but upon restarting OpenBots, an Error message pops up: NuGet.Resolver.NuGetResolverinputException: Unable to find package 'OpenBots.Commands.API'. Existing packages must be restored before performing an install or update.

This forum has 175 topics, 471 replies, and was last updated 7 hours ago by DHARANI R

Umaema Ashraf

  • Participant
  • Calender Icon May 24,2022 at 4:18 PM

Hey Nataly, Thank you for the assistance. It looks like the only issue was that even though I updated OB studio, and used the prompts to convert the scripts it was "Openbots.Core" that was still not updated to 1.8 upon installation. Once I updated that package, everything was fixed.

Nataly Alvarado

  • Participant
  • Calender Icon May 24,2022 at 5:38 AM

Hi Umaema,

To update a 1.7 project to 1.8, you can open the 1.7 project using the updated 1.8 Studio. Studio will prompt you to convert the project (once a conversion is done, it is not possible to revert the changes. Please make sure to save a backup of the original 1.7 project as precaution).

Once the main script is converted, you will need to convert any other scripts present within the project. You can do so by opening the scripts on Studio and accepting the conversion once prompted.

In addition, make sure to install any missing project dependencies from package manager and selecting the appropriate version.

You can verify the version being used by your project by checking the project's project.obconfig file. This file lists the project version and all the dependencies being referenced by the project.

Umaema Ashraf

  • Participant
  • Calender Icon May 23,2022 at 7:19 PM

Hey Nataly. Similar issue here. I have updated OB Studio to the latest version and converted the scripts to 1.8. but now they are all showing as "Broken" even though they were Native Chrome, Selenium, Desktop, and Excel commands. All of these packages appear as updated in the package manager on my end. Am I maybe missing something?

Nataly Alvarado

  • Participant
  • Calender Icon May 04,2022 at 10:04 PM

Hi crose107, ‚Äč normally the gallery and Studio are updated/published at around the same time. Before updating Studio, you can check the OpenBots Gallery site, here you'll find the list of command packages available: https://gallery.openbots.io/searchdetail

Note: v1.8 Command packages were uploaded on 05/02/2022

Chris Rose

  • Participant
  • Calender Icon May 02,2022 at 3:27 PM

Thank you Nataly. I guess it might be helpful for users who are planning to update to the latest version to know whether any of their project dependencies are not available yet. I updated to the latest version before realizing that API, Download and Image Recognition don't have 1.8.0 packages available, so I will have to downgrade until those are available.

Is there a way to see whether the newest packages have been uploaded before making the jump to the next version and finding it missing?

You are not authorized to reply, please click here to login and add your reply to this topic.