Support > Forums > OpenBots Studio > Issues With Native Chrome

Issues With Native Chrome

Joshua Menefee

  • Reporter
  • Calender Icon November 16,2021 at 11:05 PM

Earlier today, I uninstalled and did a fresh reinstall of both Studio v1.5.3 and the latest Chrome extension. Now for some reason, though, any Native Chrome command besides Create Browser that I run times out and throws the error "Error: System.InvalidOperationException: Pipe hasn't been connected yet." So far I've only tried reinstalling the extension again, and opening the Extension Manager in OpenBots Studio says that the extension is still installed despite the error still popping up. Not sure if there's anything else that I could try troubleshooting, or if this is a bug on OpenBots's end.

This forum has 172 topics, 459 replies, and was last updated 2 hours ago by Poornima Malv

Azure Backup

  • Participant
  • Calender Icon April 22,2022 at 10:12 AM

Hi POOMAL001, This solution really helpful for me,thanks for your tip.

Poornima Malviya

  • Participant
  • Calender Icon January 12,2022 at 1:49 PM

Hi Joshua and MOHKAM001,

Thankyou for reaching out. To solve the above issue please do install the latest version of OpenBots 1.7.0 and in case you face the same issue with native chrome extension. Please follow this steps -

  1. Go to Start Menu -> Search for Registry editor.
  2. Open Registry Editor
  3. Navigate as mentioned here - HKEY_CURRENT_USER> SOFTWARE> GOOGLE> CHROME> Extensions>
  4. Under extension - Do a right click and delete that extension.
  5. Go back to open bot studio and install it again. I hope this would resolve your issue. Please reach out in case of any queries.

mohamed kamal

  • Participant
  • Calender Icon January 11,2022 at 3:37 AM

Hi Nataly,

i have same problem and the file OpenBots.NativeServer.exe in not exist at the location specified in the manifest. how to solve that problem please?

Lakshmi Sukumar

  • Participant
  • Calender Icon December 09,2021 at 2:18 PM

Hello Joshua,

apologize for the delayed response. I answered this query last week, but it seems like the response wasn't posted properly.

It is difficult to troubleshoot the Native recorder without taking a closer look at the environment. Would you be able to join me in a Teams meeting for a quick troubleshooting session? if so, I'll send you a meeting invite to the email associated with this account, depending on your availability

Joshua Menefee

  • Participant
  • Calender Icon November 30,2021 at 12:11 AM

Hi Nataly,

Sorry for the late response, but yes, that OpenBots.NativeServer.exe is available at the exact path that you mentioned. Other files in the NativeServer directory include Newtonsoft.Json.dll, Newtonsoft.Json.xml, OpenBots.NativeServer.exe.config, and OpenBots.NativeServer.pdb

Nataly Alvarado

  • Participant
  • Calender Icon November 24,2021 at 4:17 PM

Joshua,

could you please check if the NativeServer executable is at the location specified in the manifest: C:\Program Files (x86)\OpenBots Inc\Extensions\NativeServer\OpenBots.NativeServer.exe

Joshua Menefee

  • Participant
  • Calender Icon November 23,2021 at 10:11 PM

Hi Nataly,

I just checked, and yes, the File Explorer path that you posted is accessible. The only file at that path is com.openbots.chromeserver.message-manifest.json, and its contents are:


{
  "$type": "OpenBots.Core.ChromeNative.ChromeNativeServer.ManifestSettings, OpenBots.Core",
  "name": "com.openbots.chromeserver.message",
  "description": "OpenBots Native Messaging Host for Chrome",
  "path": "C:\\Program Files (x86)\\OpenBots Inc\\Extensions\\NativeServer\\OpenBots.NativeServer.exe",
  "type": "stdio",
  "allowed_origins": [
    "chrome-extension://kkepankimcahnjamnimeijpplgjpmdpp/"
  ]
}

Nataly Alvarado

  • Participant
  • Calender Icon November 22,2021 at 3:56 PM

Hello Joshua,

Thanks for reaching out!

Based on the post, you have been able to use the Native Browser extension in the past, correct? If that is the case, then some misconfiguration might have occurred on the reinstallation process. For instance, folder path where the Native Browser is located and referenced by OpenBots Studio. Could you please verify that the following path is accessible through your File Explorer: "C:\Users%UserName%\AppData\Local\OpenBots Inc\OpenBots Studio\Extensions"

Also, make sure that you reference the following guide when setting up the extension: NativeRecorder_SetupGuide

Joshua Menefee

  • Participant
  • Calender Icon November 18,2021 at 1:38 AM

To add onto my original post, I did a full uninstall of both Google Chrome and OpenBots Studio, then only reinstalled Studio. My extension manager still shows that the Native Chrome extension is installed. I've never had this issue with v1.5.3 before, so I'm assuming that there's some kind of troubleshooting that I'm missing that could lead to a solution for me.

You are not authorized to reply, please click here to login and add your reply to this topic.