Support > Forums > OpenBots Studio > Issue while using Element Action to download a file

Issue while using Element Action to download a file

Rifna

  • Reporter
  • Calender Icon January 04,2021 at 10:12 AM

Hi, I am using Element Action command to perform click action to download a file from a website . After performing this action a Save As dialog box appears. When this dialog box appears, Element recorder in Element Action command was used to click the save. But this Save As dialog box didn't appear while using web element recorder. Advanced Keystrokes command was also used to perform an enter to the Save As dialog. But enter action also doesn't work. Due to these issues not able to download file. How to solve this issue?

This forum has 175 topics, 471 replies, and was last updated 6 hours ago by DHARANI R

Nataly Alvarado

  • Participant
  • Calender Icon January 05,2021 at 9:01 PM

Hi Rifna,

I would recommend to use the UIAutomation command to interact with the Save As window. You can use the element recorder included to capture the targeted element.

The Recorder tools provided in Studio, which capture actions in sequence, are still under progress so the user might encounter some errors when using it.

Please reach out to us for any questions and have a great weekend !

Rifna

  • Participant
  • Calender Icon January 05,2021 at 1:20 PM

When I tried to interact with Save As dialog box using Advanced UI recorder there occurs an error like "error cloning element". How to solve this?

Nataly Alvarado

  • Participant
  • Calender Icon January 04,2021 at 6:10 PM

Hello Rifna,

The Save As dialog box that appears after clicking download does not have the properties of a website element, which is why you are not able to capture the element using the element action command. In order to interact with the Save As window you can use the UI Automation command. This command allows you to record UI elements and perform multiple element actions such as Click Element and Set text. In addition, I would recommend to include a check in your automation to ensure that the Save As dialog box has loaded. The UI automation command has the Wait For Element To Exist action. You could also use the If GUI element exists command, or the pause script command to add a delay.

Hope this helps!

You are not authorized to reply, please click here to login and add your reply to this topic.