Support > Forums > OpenBots Studio > Invalid security certificate

Invalid security certificate

David Santos

  • Reporter
  • Calender Icon July 31,2021 at 3:37 PM

Hello Openbots experts, When trying to replicate the RPA challenge exercise with the 1.5.2 version of the Openbot studio, once the agent opens the web page I got a message from Chrome saying that this site is not secure, so the browser asks if that you really wanted to enter in this site. For this, I have to clic in in the link "Access to rpachallenge (not safe)". To overcome this incovenience I have tried to use the web element recorder to capture this step in the whole list of automations, however the web recorder got the following mesagge once the url of rpachallenge is entered:

www.rpachallenge.com uses an invalid security certificate. The certificate is only valid for the following names: *.azurewebsites.net, *.scm.azurewebsites.net, *.azure-mobile.net, *.scm.azure-mobile.net, *.sso.azurewebsites.net
Error code: SSL_ERROR_BAD_CERT_DOMAIN

Could you provide guidance to treat with not secure sites.

Thank you in advance.

David S.

This forum has 172 topics, 459 replies, and was last updated 2 hours ago by Poornima Malv

Kris R

  • Participant
  • Calender Icon August 19,2021 at 11:30 AM

Well this is still a problem, while the code doesnt get interrupted on attempting to access domains with expired certificates, the webrecorder does not allow you to proceed any further, this applies for all cases of certificate errors (Expired certificates, mismatched domains etc)

would it be possible to remove the certificate check prior to the recorder initialize? can we have it as a setting so that we can control which ones we would wish to allow? Today, if there is a security error, the only way to proceed ahead is to manually identify the components and plug in.

GEtting this check out would help immensely.

Jan Renec

  • Participant
  • Calender Icon August 13,2021 at 10:44 AM

Do not use https://www.rpachallenge.com/

but http://www.rpachallenge.com/ ( http proto is not using certificates )

David Santos

  • Participant
  • Calender Icon August 13,2021 at 10:42 AM

I could solve this issue since it was generated as result of a typo. Instead of "http://rpachallenge.com" the activity had the URL "https://rpachallenge.com". Thanks!

David Santos

  • Participant
  • Calender Icon August 13,2021 at 10:40 AM

Hi Natali, I have realized that instead of being using http://rpachallange.com my script contained the URL https://rpachallange.com. This typo was proving the error message. Now it works fine. Thank you!

Nataly Alvarado

  • Participant
  • Calender Icon August 10,2021 at 5:25 AM

Hello David,

what is the URL you are using as input for the Create Browser/Chrome command?

You are not authorized to reply, please click here to login and add your reply to this topic.