Support > Forums > OpenBots Studio > I am not seeing Credentials command on my openbots studio

I am not seeing Credentials command on my openbots studio

Athul Kakathkar

  • Reporter
  • Calender Icon April 09,2021 at 10:18 AM

Where can I find the commands related to credentials on openbots studio ?

This forum has 175 topics, 471 replies, and was last updated 7 hours ago by DHARANI R

Andy Menon

  • Participant
  • Calender Icon July 29,2021 at 4:14 AM

Hello and thanks for the response.

To your point:

If the Xpath is entered manually, make sure it is the only checked field and that it is formatted as a string ex: �//*[@ng-reflect-name=�labelCompanyName�]�

I have tried this several times and I am sure that I have checked only XPath and yet it threw errors. Later, after I tried the Recorder feature and selected a control from the Browser, I saw that the recorder has populated every available attribute, but enabled a couple of them automatically. This is different from what I was trying to do. I was trying to create a selector from scratch by putting in just the XPath, but it kept failing as the activity complained that other inputs are required.

Thanks

Nataly Alvarado

  • Participant
  • Calender Icon July 28,2021 at 9:47 AM

Hello Andy,

There have been many updates included after the Studio and Server v1.5.0 release, which may result in inconsistencies when following our website's documentation. You mention that you are following the RPA Challenge demo, in the description it states that the demo was made utilizing Studio v1.4.0, so there are some changes you may need to take into account.

For instance, variables/arguments will now be referenced without curly braces: {varX} -> varX and String inputs will now require quotation marks: My Input -> �My Input�. This is because all Studio commands and inputs now follow C# syntax rules. You can find documentation about the changes in our release notes: OpenBots Studio v1.5.0 Release Notes OpenBots Studio v1.5.2 Release Notes

For the particular example you mention, the commands used can be found under the Web Browser command group, the only difference is that the word "Selenium" has been added to the name. You can also automate the challenge using the Native Chrome command group. The difference is that Web Browser commands use selenium as the engine, while the Native Chrome commands work natively with Chrome. If the Xpath is entered manually, make sure it is the only checked field and that it is formatted as a string ex: "//*[@ng-reflect-name='labelCompanyName']"

Please let me know if there is any specific step you would like clarification on, I'll gladly help you resolve it.

Andy Menon

  • Participant
  • Calender Icon July 27,2021 at 11:40 PM

Okay! I have managed to resolve this using the Recorder and figuring out how the Selectors work. In the course v1.4 Studio is used and if that course is followed with v1.5, the Browser actions don't work as demonstrated.

And my rpachallenge works in v1.5!

https://www.awesomescreenshot.com/video/4633094?key=8a1cc8bc2a259130c17c4b024861f149

Andy Menon

  • Participant
  • Calender Icon July 27,2021 at 5:17 PM

I have a related and similar question. I have the Studio 1.5. I see severe disconnects between your Academy courses and the Studio palette. This is my 5th RPA tool and therefore I'm not new to RPA. I try to solve these issues myself before posting to the forums.

For starters, I'm trying to get through the RPA Challenge Example. I don't see any of the Commands under the Web Browser in my studio that I see in the Course.

So I tried the only "Native Chrome Get Text" command that is available to me and even that is failing with nagging errors. I'm trying to figure out what else it needs to stop showing these errors.

For starters, the insert variables does not put in the variables surrounded with the "{" "}". Even if I put them in manually, it's not working. The Selector input is nagging with an "input required" error even after putting in the XPath and unchecking all the other options

Can you please help? I'm sure that I have followed all the steps to install Studio correctly. Even then, I maybe missing something here.

thanks

Nataly Alvarado

  • Participant
  • Calender Icon April 12,2021 at 6:24 AM

Hi Athul,

I am glad you were able to access the Credential command. Each command asks for specific parameter fields, for the credential command please follow the below guidelines:

  • Username: Create a variable of type String
  • Password: Create a variable of type SecureString. You can find it in the variable list as System.Security.SecureString

In order to know which kind of input each command parameter expects, please hover over the field's name. This will show you a tooltip that includes a description, variable type(s) accepted and a sample.

Athul Kakathkar

  • Participant
  • Calender Icon April 12,2021 at 5:25 AM

I am not able to set the output username and output password. Both the fields are not accepting any value

Athul Kakathkar

  • Participant
  • Calender Icon April 12,2021 at 5:13 AM

Thanks a lot. Worked like Magic !

Nataly Alvarado

  • Participant
  • Calender Icon April 09,2021 at 2:38 PM

Hello Athul,

Thanks for reaching out to us. When installing OpenBots Studio, certain command groups are included as default such as Excel and Web Browser commands. The command groups not included as default can installed as package dependencies in a project to project basis. This is the case for the OpenBots.Commands.Server command group, which includes: Asset, Credential, QueueItem and Server Email commands. In order to install any wanted package, please follow the below steps:

  • Click Package Manager located on the top toolbar.
  • Double-click �Gallery� located on the left-side menu under 'All Packages'. Search for the package using the Search bar displayed above. In this case search for the OpenBots.Commands.Server package.
  • Once the Package shows up in the result window, click the package and click install in the Right section to install the package. You are allowed to indicate the preferred version of the package to install.

After installation is completed, the Credential command should be ready to use on your Commands list.

Hope this helps!

You are not authorized to reply, please click here to login and add your reply to this topic.