Support > Forums > OpenBots Studio > HOW TO USE

HOW TO USE

Adam Damiano

  • Reporter
  • Calender Icon November 16,2020 at 5:06 PM

Hello. Will there be sample videos on youtube ? I am totally lost on how to use Openbots. I do have another third party RPA program, however I want to learn more about Openbots. Thanks

This forum has 172 topics, 459 replies, and was last updated an hour ago by Poornima Malv

Lakshmi Sukumar

  • Participant
  • Calender Icon December 04,2020 at 6:01 PM

Hi Paras kumar, There are couple of ways you can capture the web element, manually or using Element Recorder. This would be used along with the 'Element Action' command in Web Browser Commands. Once you drag and drop 'Element Action command in the code window, follow the below steps to get the web element and perform Click. Eg: Enter some text in google search box and click Search

    Manually you would right click and click 'Inspect' to get the Id or Xpath of the web element you are trying to capture
In the Element Action, click the Element Recorder and enter the Url of the web page you are trying to capture the web elements from. You can set any of the following parameters - Xpath,Id,Name,TagName,Class Name,Link Text. Then choose the appropriate element action value - (' Set Text ' for Setting any values to Textbox / 'Invoke Click' for click actions on button ) . If you choose 'Set Text' , text to input in the search box must be given too. There are nice tutorials of the web browser commands explained in the 'How to' section of the OpenBots Studio. Please check https://openbots.ai/product/openbots-studio/how-to-guide-for-openbots-studio/ .

Hope this helps!

Paras Kumar

  • Participant
  • Calender Icon December 04,2020 at 10:49 AM

How to capture elemnts on webpage and do button clicks.?

Cameron [OpenBots]

  • Participant
  • Calender Icon November 24,2020 at 5:59 PM

Hello Vixnu,

My availability this week is tomorrow 11/25 from 11:00AM - 4:00PM EST. I am also available Friday 11/27 from 12:00PM-2:00PM EST and 3:00PM-5:00PM EST. My availability next Monday 11/30 is 11:00AM - 4:00PM EST. Please reach out to me at my email, or respond with your email here and an optimal time and I will send an invite for a call. I'll begin looking into the issues you mentioned at the bottom of your post as well.

Pedro Basto

  • Participant
  • Calender Icon November 23,2020 at 9:12 PM

Hi ch, thank you for the support, please see replies below:

� This option does not mirror the Ctrl+C function, i.e. I would like to paste the code into notepad or another code editor as an example, and this is not possible using this feature according to my limited experience with the tool, glad to be proven wrong. � Unfortunately that isnt currently possible as we do not put the commands into the clipboard when you attempt to copy them, instead storing them in the applications memory. I�ll work with the team to review our currently handling of the clipboard, and see what it would take to support the representation of copied commands as json in the clipboard.

  • This sounds great as it would facilitate and expedite development.

� I have captured the exception by taking a photo with my phone as the screenshot was just black and white as per previous description. Not sure what a �try catch� means? I was simply trying to save a screenshot of the exception and paste it into MS Paint for logging errors and so on, glad to follow any instructions or attempting to replicate the issue if necessary. � I believe I misunderstood what you meant by unhandled exception. I assumed you were referring to an exception during process execution. In that case the �Try Catch� command would allow you to implement proper error handling, catch the exception, and take the screenshot using the screenshot command. If the exception were occurring from the Studio itself that would be another matter entirely. Would you be able to provide reproduction steps/screenshots to my email mentioned below? - Unhandled exception captured - steps as follows - 1- recording Excel using UI Element Recorder, 2- then open code and add an Excel command, 3- save & close, 4- run script, then 5- double-click to open code > unhandled exception occurs, can send the details via email if you wish as the log is too long for the forums imo (unable to capture exception screenshot using Windows 10 as per previous comments). Also have other screenshots I can send via email related to other points.

� Yes, the issue does persist after restart. This is connected to previous point 4 � happy to attempt problem replication and send new screenshot as required. � This is not the case as I always close the execution/open engine window. I shall attempt to find this setting to see if this resolves the problem � could you please let me know the precise setting name/navigation path?

  • The setting to have the engine automatically close is in Options -> Settings -> Automation Engine -> Automatically Close Debug Window. - I have now applied this setting - will monitor progress and keep you updated.

� If you would be able to send the zipped up project, as well as a screenshot/steps to ch@openbots.ai I would greatly appreciate it! If we are unable to track down these issues through your provided information would you be available for a call to investigate sometime next week? - Yes, I can definitely make myself available for a call when needed, let me know the best date and time for yourselves, I am currently in the GMT time zone.

� Looking forward to the new version. I was wondering if I should post future questions over on Github as well? Or will these be communicated to the Dev team? Also, I noticed there is a new Studio version (2.1.1.0) but this is unavailable to download and install � any updates on this? � GitHub is another great place to reach us. The team monitors both the Forums and the GitHub Issues, so you can feel free to post your questions wherever you prefer. I am the Product Development Lead, so I take this issues right to the team. In this case we have the �check for updates� button pointed to an outdated resource from our testing. I will work on getting a correction in for this. Our most up to date version is v1.1. - We thought this may have been the case as the new version wasn't available anywhere we looked, thanks for the clarification and looking forward to the new version!

I have compiled additional questions/comments as previously promised (still WIP, more to come):

  • Not detecting open/home/new file buttons on left hand side of MS Excel using UI Element Recorder.

  • Advanced UI Element Recorder - After selecting the application, the "sequence recorder settings" window appears, however, there are no instructions available on what this does and what each parameter means. "AutomationID" is the only parameter slected by default. (screenshots available).

  • The Advanced UI Element Recorder window is not intuitive or easy to use. I was left wondering if the Studio was actually recording or not after pressing the "Record" red button - to my surprise it actually wasn't so had to recapture transaction from scratch. Would highly recommend to add a message/function/icon telling the developer recording has actually started and/or conversely finished.

  • Pressing "F2" once the recording stops (Excel application recording only - note other applications such as Notepad seemed to work well) does not seem to trigger any action from the tool, i.e. the Advanced UI Element Recorder window remains open and nothing else happens - this seems bugged imo. Again, the "Browse" feature is a much needed requirement here since I spent a good amount of time trying to make Excel appear in the "Recent apps" list.

  • Unhandled exception has now been captured as per previous comment, however, still unable to capture screenshot for the exception using Windows 10. This detailed exception log is available in notepad file as it is too long to post here. Also available is a screenshot containing 7 icons of Openbots studio within the icon taskbar (as raised previously, managed to replicate) whilst no execution window or process/script is running, i.e. while studio is idle.

That's all for now, once again thank you for your time and support, much appreciated.

Cameron [OpenBots]

  • Participant
  • Calender Icon November 20,2020 at 8:52 PM

Apologies, I missed your question about the engine setting. The setting to have the engine automatically close is in Options -> Settings -> Automation Engine -> Automatically Close Debug Window.

Cameron [OpenBots]

  • Participant
  • Calender Icon November 20,2020 at 8:31 PM

Vixnu, please see my responses below.

� This option does not mirror the Ctrl+C function, i.e. I would like to paste the code into notepad or another code editor as an example, and this is not possible using this feature according to my limited experience with the tool, glad to be proven wrong. - Unfortunately that isnt currently possible as we do not put the commands into the clipboard when you attempt to copy them, instead storing them in the applications memory. I'll work with the team to review our currently handling of the clipboard, and see what it would take to support the representation of copied commands as json in the clipboard.

� I have captured the exception by taking a photo with my phone as the screenshot was just black and white as per previous description. Not sure what a �try catch� means? I was simply trying to save a screenshot of the exception and paste it into MS Paint for logging errors and so on, glad to follow any instructions or attempting to replicate the issue if necessary. - I believe I misunderstood what you meant by unhandled exception. I assumed you were referring to an exception during process execution. In that case the "Try Catch" command would allow you to implement proper error handling, catch the exception, and take the screenshot using the screenshot command. If the exception were occurring from the Studio itself that would be another matter entirely. Would you be able to provide reproduction steps/screenshots to my email mentioned below?

� Yes, the issue does persist after restart. This is connected to previous point 4 � happy to attempt problem replication and send new screenshot as required. � This is not the case as I always close the execution/open engine window. I shall attempt to find this setting to see if this resolves the problem � could you please let me know the precise setting name/navigation path? - If you would be able to send the zipped up project, as well as a screenshot/steps to ch@openbots.ai I would greatly appreciate it! If we are unable to track down these issues through your provided information would you be available for a call to investigate sometime next week?

� Looking forward to the new version. I was wondering if I should post future questions over on Github as well? Or will these be communicated to the Dev team? Also, I noticed there is a new Studio version (2.1.1.0) but this is unavailable to download and install � any updates on this? - GitHub is another great place to reach us. The team monitors both the Forums and the GitHub Issues, so you can feel free to post your questions wherever you prefer. I am the Product Development Lead, so I take this issues right to the team. In this case we have the "check for updates" button pointed to an outdated resource from our testing. I will work on getting a correction in for this. Our most up to date version is v1.1.

Thank you for your patience with these issues. The given feedback does wonders towards making this a stronger platform, and we really appreciate it.

Pedro Basto

  • Participant
  • Calender Icon November 19,2020 at 8:21 PM

Hi, thank you for taking the time to address my queries, please see my observations to your comments below:

1- From a UI standpoint, website instructions are missing explanations for �UI Element Recorder�, �Advanced UI Element Recorder� and �Breakpoint�. � I will work with the team to create Recording and Debugging Scripts documentation for the site to resolve this. Please let me know if there are other major features that you feel lack sufficient documentation. - This would be fantastic as I have been struggling to find out what these do via trial and error. I will suggest a few more features that lack documentation in due course, still working on it.

2- Unable to �Copy Selected Code� within Sequence Command using edit mode. � If you�re looking to move the code out of the sequence we provide a �move out to parent� option that could assist. - This option does not mirror the Ctrl+C function, i.e. I would like to paste the code into notepad or another code editor as an example, and this is not possible using this feature according to my limited experience with the tool, glad to be proven wrong.

3- Unable to edit code and time interval between/for existing steps (scripts captured using UI Element Recorder) � this is a MAJOR impediment for development. � [Resolved as mentioned in follow-up post.]

4- Unable to take screenshots when unhandled exceptions occur � screenshot taken is portrayed in black & white with no text or visible/discerning screen elements. � Screenshots appear to work properly when I utilize the Take Screenshot command on my machine. If you would like to take a screenshot when an error occurs I would recommend utilizing a try-catch and placing the logic to take and save the screenshot into the standard Exception catch block. Would you be able to send your script through so that we can validate any issues around the circumstances of your screenshots? - I have captured the exception by taking a photo with my phone as the screenshot was just black and white as per previous description. Not sure what a "try catch" means? I was simply trying to save a screenshot of the exception and paste it into MS Paint for logging errors and so on, glad to follow any instructions or attempting to replicate the issue if necessary.

5- Unhandled exceptions occur when inserting new steps into an existing recording using the �Commands� tab. � Unfortunately I�ve been unable to reproduce this. Would you be able to provide an any information around the specific command you are trying to insert? Does this issue persist after a restart of the Studio? - Yes, the issue does persist after restart. This is connected to previous point 4 - happy to attempt problem replication and send new screenshot as required.

6- Every unhandled exception create a new OpenBots icon inside the icon taskbar menu, increasing exponentially as more exceptions are found. � I believe in this case you might be simply leaving the engine windows open when execution has completed. Each open engine window will remain until manually closed, or the option in �Settings� is changed to have them auto-close. Please let me know if this is not the case and I will investigate further. - This is not the case as I always close the execution/open engine window. I shall attempt to find this setting to see if this resolves the problem - could you please let me know the precise setting name/navigation path?

7- Screen resolution seems to be an important factor whilst recording (as reflected on code) but tips for this can�t be found anywhere within the website instructions (as far as I can see). � In the case of the �UI Recorder� the recorded actions are coordinate located rather than through defined elements. Generally speaking, we would recommend the usage of the Advanced UI Element Recorder to capture elements contained in applications, which will work regardless of resolution. Our documentation on the recording features is a bit lacking at the moment, as mentioned in point 1. I�ll work with the team to get some proper documentation up on the site. - This is excellent news since me and my team find having the recorder a massive development advantage in terms of time and efficiency. We were not using the Advanced UI Element Recorder so this may explain why we were having so many problems, we shall switch to this recording mode from now on, many thanks.

8- Advanced UI Element Recorder � no �Browse� application/element function. Additionally, tool is unable to refresh drop down list with the recent list of opened applications. � Looks like we only generate the list when the recorder is opened. We plan to revisit the recorders during our development next week and can look to implement an automatic refresh when the dropdown is selected. I will discuss the possibility of a �Browse� feature to open an application and begin automating in it. - This sounds great as certain applications are quite heavy/exclusive/proprietary and being able to select a particular one could be an advantage or so I would like to think.

9- The UI Recorder script seems to break often when cross platforming or longer transactions are recorded (UI and screen resolution remained unchanged after recording.). � I�ll need to do a deeper investigation into this. I suspect it may be due to the way we store the information while recording, and will work with the team to resolve it. - Again, excellent that you guys are so proactive. Having said that, we shall switch to the Advanced UI Element Recorder for the time being to see if we can circumvent some of the issues found.

Our v1.2 release is currently slated for mid-December. I will add the above discussed issues into our roadmap, so that we can resolve as many of them as possible in the next release. - Looking forward to the new version. I was wondering if I should post future questions over on Github as well? Or will these be communicated to the Dev team? Also, I noticed there is a new Studio version (2.1.1.0) but this is unavailable to download and install - any updates on this?

Thanks in advance for your support.

Cameron [OpenBots]

  • Participant
  • Calender Icon November 18,2020 at 8:36 PM

Hello Vixnu.

We really appreciate the feedback on the Studio. I have provided an answer for each of your above points below.

1- From a UI standpoint, website instructions are missing explanations for �UI Element Recorder�, �Advanced UI Element Recorder� and �Breakpoint�.

  • I will work with the team to create Recording and Debugging Scripts documentation for the site to resolve this. Please let me know if there are other major features that you feel lack sufficient documentation.

2- Unable to �Copy Selected Code� within Sequence Command using edit mode.

  • If you're looking to move the code out of the sequence we provide a "move out to parent" option that could assist.

3- Unable to edit code and time interval between/for existing steps (scripts captured using UI Element Recorder) � this is a MAJOR impediment for development.

  • [Resolved as mentioned in follow-up post.]

4- Unable to take screenshots when unhandled exceptions occur � screenshot taken is portrayed in black & white with no text or visible/discerning screen elements.

  • Screenshots appear to work properly when I utilize the Take Screenshot command on my machine. If you would like to take a screenshot when an error occurs I would recommend utilizing a try-catch and placing the logic to take and save the screenshot into the standard Exception catch block. Would you be able to send your script through so that we can validate any issues around the circumstances of your screenshots?

5- Unhandled exceptions occur when inserting new steps into an existing recording using the �Commands� tab.

  • Unfortunately I've been unable to reproduce this. Would you be able to provide an any information around the specific command you are trying to insert? Does this issue persist after a restart of the Studio?

6- Every unhandled exception create a new OpenBots icon inside the icon taskbar menu, increasing exponentially as more exceptions are found.

  • I believe in this case you might be simply leaving the engine windows open when execution has completed. Each open engine window will remain until manually closed, or the option in "Settings" is changed to have them auto-close. Please let me know if this is not the case and I will investigate further.

7- Screen resolution seems to be an important factor whilst recording (as reflected on code) but tips for this can�t be found anywhere within the website instructions (as far as I can see).

  • In the case of the "UI Recorder" the recorded actions are coordinate located rather than through defined elements. Generally speaking, we would recommend the usage of the Advanced UI Element Recorder to capture elements contained in applications, which will work regardless of resolution. Our documentation on the recording features is a bit lacking at the moment, as mentioned in point 1. I'll work with the team to get some proper documentation up on the site.

8- Advanced UI Element Recorder � no �Browse� application/element function. Additionally, tool is unable to refresh drop down list with the recent list of opened applications.

  • Looks like we only generate the list when the recorder is opened. We plan to revisit the recorders during our development next week and can look to implement an automatic refresh when the dropdown is selected. I will discuss the possibility of a "Browse" feature to open an application and begin automating in it.

9- The UI Recorder script seems to break often when cross platforming or longer transactions are recorded (UI and screen resolution remained unchanged after recording.).

  • I'll need to do a deeper investigation into this. I suspect it may be due to the way we store the information while recording, and will work with the team to resolve it.

Our v1.2 release is currently slated for mid-December. I will add the above discussed issues into our roadmap, so that we can resolve as many of them as possible in the next release.

Pedro Basto

  • Participant
  • Calender Icon November 17,2020 at 5:29 PM

Please ignore point 3.

Pedro Basto

  • Participant
  • Calender Icon November 17,2020 at 5:03 PM

Hi, thanks for the information provided above. I have read all of the "Getting Started" sections, including "User Interface" and "Creating your First Bot", however, there are quite a few gaps/teething issues and questions I would like to present at this early stage:

1- From a UI standpoint, website instructions are missing explanations for "UI Element Recorder", "Advanced UI Element Recorder" and "Breakpoint". 2- Unable to "Copy Selected Code" within Sequence Command using edit mode. 3- Unable to edit code and time interval between/for existing steps (scripts captured using UI Element Recorder) - this is a MAJOR impediment for development. 4- Unable to take screenshots when unhandled exceptions occur - screenshot taken is portrayed in black & white with no text or visible/discerning screen elements. 5- Unhandled exceptions occur when inserting new steps into an existing recording using the "Commands" tab. 6- Every unhandled exception create a new OpenBots icon inside the icon taskbar menu, increasing exponentially as more exceptions are found. 7- Screen resolution seems to be an important factor whilst recording (as reflected on code) but tips for this can't be found anywhere within the website instructions (as far as I can see). 8- Advanced UI Element Recorder - no "Browse" application/element function. Additionally, tool is unable to refresh drop down list with recent list of opened applications. 9- The UI Recorder script seems to break often when cross platforming or longer transactions are recorded (UI and screen resolution remained unchanged after recording).

Thanks in advance for your help.

You are not authorized to reply, please click here to login and add your reply to this topic.