Support > Forums > OpenBots Studio > Facing debug error on send outlook email

Facing debug error on send outlook email

Jamuna T

  • Reporter
  • Calender Icon February 18,2021 at 10:02 AM

Hi, I need to send the mail with output excel attachment, while using send outlook email command facing debug error like this

Couldnot load file or assembly ' office, version=15.0.0.0, Culture=neutral, publicKeyToken=71e9bce111e9429c' or one of its dependencies, The system cannot find the file specified. File name: 'office, Version-15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' at OpenBots.Commands.Outlook.SendOutlookEmailCommand.RunCommand(Obje ct sender) at OpenBots.Engine.AutomationEngineInstance.ExecuteCommand(ScriptAction command)

Can anyone guide me please how to solve this error. Thanks.

This forum has 172 topics, 459 replies, and was last updated 1 hours ago by Poornima Malv

Jamuna T

  • Participant
  • Calender Icon March 11,2021 at 9:26 AM

Hi,

Thanks for your response and clarification Nataly.

Nataly Alvarado

  • Participant
  • Calender Icon March 10,2021 at 10:33 PM

Hello Jamuna,

I apologize for the delayed response. The development team has been notified of the issues you are facing while employing Microsoft Outlook 2007. The interop has changed significantly since that version, which causes our current implementation to not work as expected. However, our team is constantly working on new additions and improvements to Studio as new versions are released. We will revise this case and add support in future implementations as resources become available.

best regards, Nataly

Jamuna T

  • Participant
  • Calender Icon March 08,2021 at 1:04 PM

Hi, Openbots will support 2007 version of Microsoft outlook ? Can anyone provide clarification for this Thanks.

Jamuna T

  • Participant
  • Calender Icon February 26,2021 at 9:58 AM

Hi,

Thanks for your response and Server clarification Nataly. Yes I can able to use other Microsoft commands like (excel and word ) in my OpenBots studio tool and The version of my outlook app is Microsoft outlook 2007. Thanks.

Nataly Alvarado

  • Participant
  • Calender Icon February 25,2021 at 7:46 PM

Hello Jamuna,

thank you for sharing the above information. I would like to pinpoint the cause of the issue, could you please check if you are able to use other Microsoft commands (Excel and Word)? Also, what version of Outlook app do you have installed on your machine? Hopefully, this information will allow us to get closer to the root of the problem. In regards to your question, you don't need to have Server installed to be able to interact with the Outlook commands. Only the commands included in the OpenBots.Commands.Server package need a connection to Server in order to function.

best regards, Nataly

Jamuna T

  • Participant
  • Calender Icon February 22,2021 at 11:49 AM

Hi,

Thanks for your response Nataly. I have mentioned some information below for the clarification.

Yes I can able to open & interact with the outlook desktop app from the current machine running studio I have installed V1.3.0 version of OpenBots Studio only. Yes I am attempting to run built on the same version of studio and I have checked the project.config file and packages as per your suggestion Its showing 1.3.0 version only. I don't know where I am doing the mistakes Kindly guide me to move on from this.
One more clarification shall I need to installed OpenBots server to send outlook mail? Thanks in advance.

Nataly Alvarado

  • Participant
  • Calender Icon February 18,2021 at 6:13 PM

Hello Jamuna,

Thanks for reaching out to us. There are a couple factors that could be causing the issue you describe. In order to help you troubleshoot, I would like to obtain some information.

  • Are you able to open and interact with the Outlook Desktop app from the machine running Studio?
  • What version of OpenBots Studio do you have installed
  • Was the project you are attempting to run built on the same version of Studio, or was it built on a previous version? You can check your project version by inspecting its project.config file. In addition, check the project's Outlook command version also present in the project.config file (for example, version 1.3.0 lists the dependency as: "OpenBots.Commands.Microsoft":"1.3.0")

Please, let me know if you are able to find the above information.

Best Regards,

Nataly

You are not authorized to reply, please click here to login and add your reply to this topic.