Support > Forums > OpenBots Server > SSL Certificate generation issue

SSL Certificate generation issue

David Santos

  • Reporter
  • Calender Icon August 08,2021 at 11:39 AM

Hi Openbots expert,

When executing manually a process in the Openbots Server I got the message error "Job Execution | Log Message: Error occurred while executing the job; ErrorMessage = OpenBots.Service.API.Client.ApiException: Error calling GetCredential:..."

I found other messages in the forum pointing out to the creation of a SSL certificate. I have followed all the steps to generate the Self-Signed Certificate as per the documentation in https://academy.openbots.ai/lessons/self-signed-certification-creation-and-binding-for-sandbox-environment-2/ but I could not complete the final step to aggregate the certificate in the Bindings area. Once I aggregate the new "OpenbotsCertificate" as a new site binding the agent lost its connection to the server. I tried to use port 81 instead of 443 indicated in the guidelines but the system warns me that this port is already in use by the localhost (the one used by the server).

As my Agent is not connected, when I run a process manually in the server, this error come up: Exception when calling CredentialsApi.GetCredentials: Error calling GetCredential with status 403: Forbidden

Can you provide guidance to be able to execute processes from the server in a manual way?

Thank you in advance.

This forum has 36 topics, 136 replies, and was last updated one month ago by Rajeena Mashnampat

Nataly Alvarado

  • Participant
  • Calender Icon October 21,2021 at 4:18 PM

@Dinesh, please reference the following forum thread: https://openbots.ai/forums/topic/unable-to-connect-openbots-cloud-server-and-agent-401-error/#post-10475

dinesh s

  • Participant
  • Calender Icon October 21,2021 at 3:23 PM

Hi Team,

Please help me in connecting Agent and Server. I have recently brought Openbots Cloud server. While adding agent details in server at the place of IP address I added the IPv4 address from Commang Prompt "IPCONFIG", Is this correct way.

dinesh s

  • Participant
  • Calender Icon October 21,2021 at 3:02 PM

I am trying to connect to Openbots Agent from Openbots Cloud server. Have first created credential vault in server. Then Added the agent where I gave username and Password.

What ever username and password I gave in add agent in server. Same was given in Agent .

I selected Orchestrator Openbots Cloud server. Given the Organization..

but unable to connect the server and agent. Exception when calling AuthApi.RefreshToken:Status Code:Unauthorized � Error Message: {�Type�:�https://tools.ietf.org/html/rfc7235#section-3.1″,�title�:�Unauthorized�, �status�:401,�traceid�:�00-b53a7eaXXXXXX-00"} Kindly help us to rectify this above error.

dinesh s

  • Participant
  • Calender Icon October 21,2021 at 2:57 PM

Hi Openbots Team, We are unable to connect Openbots Could Server. Getting below error. Exception when calling AuthApi.RefreshToken:Status Code:Unauthorized - Error Message: {"Type":"https://tools.ietf.org/html/rfc7235#section-3.1","title":"Unauthorized", "status":401,"traceid":"00-b53a7eaXXXXXX-00"} Kindly help us to rectify this above error.

David Santos

  • Participant
  • Calender Icon August 13,2021 at 1:19 PM

I finally found the issue that was preventing the connection between Agent and Server. The problem was that the value "::1" was indicated in the "IP Address" of the Agent parameters in the Server instead of the IP address obtained by the Machine info option in the Agent App.

David Santos

  • Participant
  • Calender Icon August 13,2021 at 10:40 AM

Hi Nataly, Before the inclusion of the SSL certificate I was able to log in the server (through the URL http://localhost:81/) and connect the Agent and the server, however I couldn�t run any process as commented in the opening message above of this post. Now I have included the SSL certificate and following your advice I have removed the local host in the bindings section of the Openbots Server HTTP to have just one entry. I have checked again with the new URL https://laptop-XXXX/ and I was able to enter the server successfully. So far, so good. Now when I go to the Agent to change the connection settings in the Server Configuration Area to: Orchestrator: On-Premises (no changes) Server URL: https://laptop-XXXXX/ (the new URL) User Name (no changes) Pass (no changes)

Then I clicked the "Connect" button and I got from the system this error message: Exception when calling AgentsApi.ConnectAgent: Error calling Connect Agent with status BadRequest: Entity Operation Exception. The IP address provided does not match this agent�s IP address

I am not sure if in the "logging" changes should be also entered or if these parameters change automatically.

Can you provide guidance?

Thank you in advance.

Nataly Alvarado

  • Participant
  • Calender Icon August 10,2021 at 5:07 AM

Hello David,

as Jan mentioned, make sure you are able to navigate to the website using the https URL binded. To avoid any confusion, I would recommend to delete the localhost bind and only keep the https self-signed certificate binding.

Another thing to keep in mind, is that you need to use the new URL to connect to Agent now. As long as you are able to navigate to the site from the machine hosting Agent, you should be able to connect it.

If Agent connection does not exist, you wont be able to schedule processes to run (including manually).

Jan Renec

  • Participant
  • Calender Icon August 09,2021 at 11:36 AM

Can you connect with admin panel in www browser (and login )?

You are not authorized to reply, please click here to login and add your reply to this topic.